const regex = /(?i)^(?:https?:\/\/)?(?:www\.)?(?:[a-z0-9-]+\.){1,9}[a-z]{2,5}(?:\/.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^(?:https?:\\\/\\\/)?(?:www\\.)?(?:[a-z0-9-]+\\.){1,9}[a-z]{2,5}(?:\\\/.*)?$', 'gm')
const str = `www.google.com
google.com
drive.google.com
http://www.google.com
http://google.com
http://drive.google.com
https://www.google.com
https://www.google.com
https://www.drive.google.com
https://www.google.com/some_other_things
https://www.google.com/
https://www.drive.google.com/
https://www.a.a.a.a.a.a.a.a.a.google.com/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}