# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)^(?:https?:\/\/)?(?:www\.)?(?:[a-z0-9-]+\.){1,9}[a-z]{2,5}(?:\/.*)?$"
test_str = ("www.google.com\n"
"google.com\n"
"drive.google.com\n"
"http://www.google.com\n"
"http://google.com\n"
"http://drive.google.com\n"
"https://www.google.com\n"
"https://www.google.com\n"
"https://www.drive.google.com\n"
"https://www.google.com/some_other_things\n"
"https://www.google.com/\n"
"https://www.drive.google.com/\n"
"https://www.a.a.a.a.a.a.a.a.a.google.com/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.