use strict;
my $str = 'www.google.com
google.com
drive.google.com
http://www.google.com
http://google.com
http://drive.google.com
https://www.google.com
https://www.google.com
https://www.drive.google.com
https://www.google.com/some_other_things
https://www.google.com/
https://www.drive.google.com/
https://www.a.a.a.a.a.a.a.a.a.google.com/';
my $regex = qr/(?i)^(?:https?:\/\/)?(?:www\.)?(?:[a-z0-9-]+\.){1,9}[a-z]{2,5}(?:\/.*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}