re = /(?i)^(?:https?:\/\/)?(?:www\.)?(?:[a-z0-9-]+\.){1,9}[a-z]{2,5}(?:\/.*)?$/m
str = 'www.google.com
google.com
drive.google.com
http://www.google.com
http://google.com
http://drive.google.com
https://www.google.com
https://www.google.com
https://www.drive.google.com
https://www.google.com/some_other_things
https://www.google.com/
https://www.drive.google.com/
https://www.a.a.a.a.a.a.a.a.a.google.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end