// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^(?:https?:\/\/)?(?:www\.)?(?:[a-z0-9-]+\.){1,9}[a-z]{2,5}(?:\/.*)?$").unwrap();
let string = "www.google.com
google.com
drive.google.com
http://www.google.com
http://google.com
http://drive.google.com
https://www.google.com
https://www.google.com
https://www.drive.google.com
https://www.google.com/some_other_things
https://www.google.com/
https://www.drive.google.com/
https://www.a.a.a.a.a.a.a.a.a.google.com/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}