#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)(?<qt>['"`])(?<string>.*?(?<!\\)\1)|(?<delimiter>[;{}\n]|^)(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<beforeSLCmnt>.*)(?:\/\/.*$)|(?<beforeMLCmnt>.*)(?:\/\*+(?:.|\s)*\*\/)|\s*"
Local $sString = "function myFunction() {" & @CRLF & _
" let carName = "Volvo";" & @CRLF & _
" 'sdf'// here is a comment, string before it should still exist" & @CRLF & _
"let banana" & @CRLF & _
" const test = 'string with "quoted substring"'; let airplane = 'fly';" & @CRLF & _
"("and another string th'' as' asd 'ere")" & @CRLF & _
"'escaped \' character '" & @CRLF & _
"labelForStrings: {" & @CRLF & _
" `t'is a\` "string"`" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"const variableShouldStillExist /*asd *****" & @CRLF & _
"* 324 @*l;;?\\\" & @CRLF & _
"* multiline comment " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*** /" & @CRLF & _
"*/" & @CRLF & _
"/* single multiline */"
Local $sSubst = "$1$2$3$4$5$6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)