using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<qt>['""`])(?<string>.*?(?<!\\)\1)|(?<delimiter>[;{}\n]|^)(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<beforeSLCmnt>.*)(?:\/\/.*$)|(?<beforeMLCmnt>.*)(?:\/\*+(?:.|\s)*\*\/)|\s*";
string substitution = @"$1$2$3$4$5$6";
string input = @"function myFunction() {
let carName = ""Volvo"";
'sdf'// here is a comment, string before it should still exist
let banana
const test = 'string with ""quoted substring""'; let airplane = 'fly';
(""and another string th'' as' asd 'ere"")
'escaped \' character '
labelForStrings: {
`t'is a\` ""string""`
}
}
const variableShouldStillExist /*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/
/* single multiline */";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}