import Foundation
let pattern = #"(?<qt>['"`])(?<string>.*?(?<!\\)\1)|(?<delimiter>[;{}\n]|^)(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<beforeSLCmnt>.*)(?:\/\/.*$)|(?<beforeMLCmnt>.*)(?:\/\*+(?:.|\s)*\*\/)|\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
function myFunction() {
let carName = "Volvo";
'sdf'// here is a comment, string before it should still exist
let banana
const test = 'string with "quoted substring"'; let airplane = 'fly';
("and another string th'' as' asd 'ere")
'escaped \' character '
labelForStrings: {
`t'is a\` "string"`
}
}
const variableShouldStillExist /*asd *****
* 324 @*l;;?\\\
* multiline comment
*** /
*/
/* single multiline */
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4$5$6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)