use strict;
my $str = 'function myFunction() {
let carName = "Volvo";
\'sdf\'// here is a comment, string before it should still exist
let banana
const test = \'string with "quoted substring"\'; let airplane = \'fly\';
("and another string th\'\' as\' asd \'ere")
\'escaped \\\' character \'
labelForStrings: {
`t\'is a\\` "string"`
}
}
const variableShouldStillExist /*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/
/* single multiline */';
my $regex = qr/(?<qt>['"`])(?<string>.*?(?<!\\)\1)|(?<delimiter>[;{}\n]|^)(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<beforeSLCmnt>.*)(?:\/\/.*$)|(?<beforeMLCmnt>.*)(?:\/\*+(?:.|\s)*\*\/)|\s*/imp;
my $subst = '$1$2$3$4$5$6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";