import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<qt>['\"`])(?<string>.*?(?<!\\\\)\\1)|(?<delimiter>[;\\{\\}\\n]|^)(?:[ \\t\\v])*(?<keyword>(?:const|let|function)\\s)|(?<beforeSLCmnt>.*)(?:\\/\\/.*$)|(?<beforeMLCmnt>.*)(?:\\/\\*+(?:.|\\s)*\\*\\/)|\\s*";
final String string = "function myFunction() {\n"
+ " let carName = \"Volvo\";\n"
+ " 'sdf'// here is a comment, string before it should still exist\n"
+ "let banana\n"
+ " const test = 'string with \"quoted substring\"'; let airplane = 'fly';\n"
+ "(\"and another string th'' as' asd 'ere\")\n"
+ "'escaped \\' character '\n"
+ "labelForStrings: {\n"
+ " `t'is a\\` \"string\"`\n"
+ " }\n"
+ "}\n"
+ "const variableShouldStillExist /*asd *****\n"
+ "* 324 @*l;;?\\\\\\\n"
+ "* multiline comment \n\n\n"
+ "*** /\n"
+ "*/\n"
+ "/* single multiline */";
final String subst = "$1$2$3$4$5$6";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}