re = /(?<qt>['"`])(?<string>.*?(?<!\\)\1)|(?<delimiter>[;{}\n]|^)(?:[ \t\v])*(?<keyword>(?:const|let|function)\s)|(?<beforeSLCmnt>.*)(?:\/\/.*$)|(?<beforeMLCmnt>.*)(?:\/\*+(?:.|\s)*\*\/)|\s*/im
str = 'function myFunction() {
let carName = "Volvo";
\'sdf\'// here is a comment, string before it should still exist
let banana
const test = \'string with "quoted substring"\'; let airplane = \'fly\';
("and another string th\'\' as\' asd \'ere")
\'escaped \\\' character \'
labelForStrings: {
`t\'is a\\` "string"`
}
}
const variableShouldStillExist /*asd *****
* 324 @*l;;?\\\\\\
* multiline comment
*** /
*/
/* single multiline */'
subst = '$1$2$3$4$5$6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result