package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(https?:\/\/)?(www\.)?((discordapp\.com/invite)|(discord\.gg))\/(\w+)`)
var str = `https://www.discord.gg/lmao
www.discord.gg/lmao
https://discord.gg/lmao
http://discord.gg/lmao
www.discord.gg/lmao
discord.gg/lmao
https://discordapp.com/invite/lmao
http://discordapp.com/invite/lmao
discordapp.com/invite/lmao
discordapp.gg/lmao`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}