re = /(https?:\/\/)?(www\.)?((discordapp\.com\/invite)|(discord\.gg))\/(\w+)/m
str = 'https://www.discord.gg/lmao
www.discord.gg/lmao
https://discord.gg/lmao
http://discord.gg/lmao
www.discord.gg/lmao
discord.gg/lmao
https://discordapp.com/invite/lmao
http://discordapp.com/invite/lmao
discordapp.com/invite/lmao
discordapp.gg/lmao'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end