import re
regex = re.compile(r"(https?:\/\/)?(www\.)?((discordapp\.com/invite)|(discord\.gg))\/(\w+)", flags=re.MULTILINE)
test_str = ("https://www.discord.gg/lmao\n"
"www.discord.gg/lmao\n\n"
"https://discord.gg/lmao\n"
"http://discord.gg/lmao\n"
"www.discord.gg/lmao\n"
"discord.gg/lmao\n"
"https://discordapp.com/invite/lmao\n"
"http://discordapp.com/invite/lmao\n"
"discordapp.com/invite/lmao\n\n"
"discordapp.gg/lmao")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")