use strict;
my $str = 'https://www.discord.gg/lmao
www.discord.gg/lmao
https://discord.gg/lmao
http://discord.gg/lmao
www.discord.gg/lmao
discord.gg/lmao
https://discordapp.com/invite/lmao
http://discordapp.com/invite/lmao
discordapp.com/invite/lmao
discordapp.gg/lmao';
my $regex = qr/(https?:\/\/)?(www\.)?((discordapp\.com/invite)|(discord\.gg))\/(\w+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}