# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!^)[A-Z]+|(?<!^|\d)[\d]+/-$0/gm;t' <<< "foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar"