use strict;
my $str = 'foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar';
my $regex = qr/(?<!^)[A-Z]+|(?<!^|\d)[\d]+/mp;
my $subst = '-$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";