#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!^)[A-Z]+|(?<!^|\d)[\d]+"
Local $sString = "foo" & @CRLF & _
"fooBar" & @CRLF & _
"foo123" & @CRLF & _
"123Foo" & @CRLF & _
"fooBar123" & @CRLF & _
"foo123Bar" & @CRLF & _
"123FooBar"
Local $sSubst = "-$0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)