import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!^)[A-Z]+|(?<!^|\\d)[\\d]+";
final String string = "foo\n"
+ "fooBar\n"
+ "foo123\n"
+ "123Foo\n"
+ "fooBar123\n"
+ "foo123Bar\n"
+ "123FooBar";
final String subst = "-$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}