import re
regex = re.compile(r"(?<!^)[A-Z]+|(?<!^|\d)[\d]+", flags=re.MULTILINE)
test_str = ("foo\n"
"fooBar\n"
"foo123\n"
"123Foo\n"
"fooBar123\n"
"foo123Bar\n"
"123FooBar")
subst = "-$0"
result = regex.sub(subst, test_str)
if result:
print(result)