re = /(?<!^)[A-Z]+|(?<!^|\d)[\d]+/m
str = 'foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar'
subst = '-$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result