using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\$(?<gross>\d+)\s+\$(?<earnings>\d+)\s+\$(?<pension>\d+)\s+\$(?<refund>\d+)\s+\$(?<garnish>\d+)\s+\$(?<taxes>\d+)\s+\$(?<unk>\d+)\s+\$(?<net>\d+)\s+\$(?<cummTaxes>\d+)202\d{5}.+\$(?<balance>[\d,]+)";
string input = @"[0120168115100180 $231 $30 $0 $0 $0 $23 $53 $208 $2320200616 ******@*****.*** $8,778 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}