$re = '/\$(?<gross>\d+)\s+\$(?<earnings>\d+)\s+\$(?<pension>\d+)\s+\$(?<refund>\d+)\s+\$(?<garnish>\d+)\s+\$(?<taxes>\d+)\s+\$(?<unk>\d+)\s+\$(?<net>\d+)\s+\$(?<cummTaxes>\d+)202\d{5}.+\$(?<balance>[\d,]+)/m';
$str = '[0120168115100180 $231 $30 $0 $0 $0 $23 $53 $208 $2320200616 ******@*****.*** $8,778 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);