import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\$(?<gross>\\d+)\\s+\\$(?<earnings>\\d+)\\s+\\$(?<pension>\\d+)\\s+\\$(?<refund>\\d+)\\s+\\$(?<garnish>\\d+)\\s+\\$(?<taxes>\\d+)\\s+\\$(?<unk>\\d+)\\s+\\$(?<net>\\d+)\\s+\\$(?<cummTaxes>\\d+)202\\d{5}.+\\$(?<balance>[\\d,]+)";
final String string = "[0120168115100180 $231 $30 $0 $0 $0 $23 $53 $208 $2320200616 ******@*****.*** $8,778 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}