import re
regex = re.compile(r"\$(?<gross>\d+)\s+\$(?<earnings>\d+)\s+\$(?<pension>\d+)\s+\$(?<refund>\d+)\s+\$(?<garnish>\d+)\s+\$(?<taxes>\d+)\s+\$(?<unk>\d+)\s+\$(?<net>\d+)\s+\$(?<cummTaxes>\d+)202\d{5}.+\$(?<balance>[\d,]+)", flags=re.MULTILINE)
test_str = "[0120168115100180 $231 $30 $0 $0 $0 $23 $53 $208 $2320200616 ******@*****.*** $8,778 "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")