const regex = /\$(?<gross>\d+)\s+\$(?<earnings>\d+)\s+\$(?<pension>\d+)\s+\$(?<refund>\d+)\s+\$(?<garnish>\d+)\s+\$(?<taxes>\d+)\s+\$(?<unk>\d+)\s+\$(?<net>\d+)\s+\$(?<cummTaxes>\d+)202\d{5}.+\$(?<balance>[\d,]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\$(?<gross>\\d+)\\s+\\$(?<earnings>\\d+)\\s+\\$(?<pension>\\d+)\\s+\\$(?<refund>\\d+)\\s+\\$(?<garnish>\\d+)\\s+\\$(?<taxes>\\d+)\\s+\\$(?<unk>\\d+)\\s+\\$(?<net>\\d+)\\s+\\$(?<cummTaxes>\\d+)202\\d{5}.+\\$(?<balance>[\\d,]+)', 'gm')
const str = `[0120168115100180 \$231 \$30 \$0 \$0 \$0 \$23 \$53 \$208 \$2320200616 ******@*****.*** \$8,778 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}