#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\-0-9xX\/]{12,21}"
Local $sString = "5/458/x-/x62x4/xxx=179" & @CRLF & _
"5/4081x-/xxx4/xx5=186" & @CRLF & _
"6272348/9-xxx638/7=153" & @CRLF & _
"8/9-44729-xx8-359/7=133" & @CRLF & _
"8-7-539/9/x8-513/9-=122"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")