// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\-0-9xX\/]{12,21}").unwrap();
let string = "5/458/x-/x62x4/xxx=179
5/4081x-/xxx4/xx5=186
6272348/9-xxx638/7=153
8/9-44729-xx8-359/7=133
8-7-539/9/x8-513/9-=122";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}