const regex = /[\-0-9xX\/]{12,21}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\-0-9xX\\\/]{12,21}', 'gm')
const str = `5/458/x-/x62x4/xxx=179
5/4081x-/xxx4/xx5=186
6272348/9-xxx638/7=153
8/9-44729-xx8-359/7=133
8-7-539/9/x8-513/9-=122`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}