$re = '/[\-0-9xX\/]{12,21}/m';
$str = '5/458/x-/x62x4/xxx=179
5/4081x-/xxx4/xx5=186
6272348/9-xxx638/7=153
8/9-44729-xx8-359/7=133
8-7-539/9/x8-513/9-=122';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);