use strict;
my $str = '5/458/x-/x62x4/xxx=179
5/4081x-/xxx4/xx5=186
6272348/9-xxx638/7=153
8/9-44729-xx8-359/7=133
8-7-539/9/x8-513/9-=122';
my $regex = qr/[\-0-9xX\/]{12,21}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}