# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:[0-9]{1,3}\. ?)?(?:<media(?::[0-9]+)? ?\/?><br ?\/?>)*(.*)$/$1/gm;t' <<< "What does the speaker suggest?
91. What does the speaker suggest?
96. <media:12 /><br />Why is the speaker going to Reynold’s Café?
96. <media:12 /><br /><media:13 /><br />Why is the speaker going to Reynold’s Café?"