re = /^(?:[0-9]{1,3}\. ?)?(?:<media(?::[0-9]+)? ?\/?><br ?\/?>)*(.*)$/m
str = 'What does the speaker suggest?
91. What does the speaker suggest?
96. <media:12 /><br />Why is the speaker going to Reynold’s Café?
96. <media:12 /><br /><media:13 /><br />Why is the speaker going to Reynold’s Café?'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result