const regex = new RegExp('^(?:[0-9]{1,3}\\. ?)?(?:<media(?::[0-9]+)? ?/?><br ?/?>)*(.*)$', 'gm')
const str = `What does the speaker suggest?
91. What does the speaker suggest?
96. <media:12 /><br />Why is the speaker going to Reynold’s Café?
96. <media:12 /><br /><media:13 /><br />Why is the speaker going to Reynold’s Café?`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);