using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[0-9]{1,3}\. ?)?(?:<media(?::[0-9]+)? ?/?><br ?/?>)*(.*)$";
string substitution = @"$1";
string input = @"What does the speaker suggest?
91. What does the speaker suggest?
96. <media:12 /><br />Why is the speaker going to Reynold’s Café?
96. <media:12 /><br /><media:13 /><br />Why is the speaker going to Reynold’s Café?";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}