import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[class\\*=(?:\"|')?(.*?)(?:\"|')?\\]";
final String string = "/***********************\n"
+ "***** SHOULD MATCH *****\n"
+ "***********************/\n\n"
+ "/* No quotes */\n"
+ "[class*=container] {}\n\n"
+ "/* Single quotes */\n"
+ "[class*='container'] {}\n\n"
+ "/* Double quotes */\n"
+ "[class*=\"container\"] {}\n\n"
+ "/* Multiple classes */\n"
+ "[class*=\"container\"][class*=\"container-large\"] {}\n\n\n\n"
+ "/**************************\n"
+ "***** SHOULDN'T MATCH *****\n"
+ "**************************/\n\n"
+ "/* With = (exactly equal) */\n"
+ "[class=\"container\"] {}\n\n"
+ "/* With ^= (begins with) */\n"
+ "[class^=\"container\"] {}\n\n"
+ "/* With $= (ends with) */\n"
+ "[class$=\"container\"] {}";
final String subst = ".$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}