re = /\[class\*=(?:"|')?(.*?)(?:"|')?\]/
str = '/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*=\'container\'] {}
/* Double quotes */
[class*="container"] {}
/* Multiple classes */
[class*="container"][class*="container-large"] {}
/**************************
***** SHOULDN\'T MATCH *****
**************************/
/* With = (exactly equal) */
[class="container"] {}
/* With ^= (begins with) */
[class^="container"] {}
/* With $= (ends with) */
[class$="container"] {}'
subst = '.$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result