const regex = /\[class\*=(?:"|')?(.*?)(?:"|')?\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[class\\*=(?:"|\')?(.*?)(?:"|\')?\\]', 'g')
const str = `/***********************
***** SHOULD MATCH *****
***********************/
/* No quotes */
[class*=container] {}
/* Single quotes */
[class*='container'] {}
/* Double quotes */
[class*="container"] {}
/* Multiple classes */
[class*="container"][class*="container-large"] {}
/**************************
***** SHOULDN'T MATCH *****
**************************/
/* With = (exactly equal) */
[class="container"] {}
/* With ^= (begins with) */
[class^="container"] {}
/* With \$= (ends with) */
[class\$="container"] {}`;
const subst = `.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);