using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*[\r\n]+)*[\}\]])|([^\n\r]*))";
string input = @"var testmultiline = {
fizz = {
buzz = ""moo""
}
buzz = {
buzz = ""moo""
}
}
var testmultiline = {
fizz = {
buzz = ""moo""
}
}
var test2 = null
var test3 = { still single line }
var test4";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}