re = /(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*[\r\n]+)*[\}\]])|([^\n\r]*))/m
str = 'var testmultiline = {
fizz = {
buzz = "moo"
}
buzz = {
buzz = "moo"
}
}
var testmultiline = {
fizz = {
buzz = "moo"
}
}
var test2 = null
var test3 = { still single line }
var test4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end