package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*[\r\n]+)*[\}\]])|([^\n\r]*))`)
var str = `var testmultiline = {
fizz = {
buzz = "moo"
}
buzz = {
buzz = "moo"
}
}
var testmultiline = {
fizz = {
buzz = "moo"
}
}
var test2 = null
var test3 = { still single line }
var test4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}