$re = '/(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*[\r\n]+)*[\}\]])|([^\n\r]*))/m';
$str = 'var testmultiline = {
fizz = {
buzz = "moo"
}
buzz = {
buzz = "moo"
}
}
var testmultiline = {
fizz = {
buzz = "moo"
}
}
var test2 = null
var test3 = { still single line }
var test4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);