// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(var.*=)\s+(([\{\[\]][^\{\}\n]*[\n\r]+(\t[^\r\n]*[\r\n]+)*[\}\]])|([^\n\r]*))").unwrap();
let string = "var testmultiline = {
fizz = {
buzz = \"moo\"
}
buzz = {
buzz = \"moo\"
}
}
var testmultiline = {
fizz = {
buzz = \"moo\"
}
}
var test2 = null
var test3 = { still single line }
var test4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}