#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<h[1-6]>"
Local $sString = "<h1> // MATCH!" & @CRLF & _
"<h3> // MATCH!" & @CRLF & _
"<h6> // MATCH!" & @CRLF & _
"h7 // NO MATCH!" & @CRLF & _
"<h7> // NO MATCH!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")