import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<h[1-6]>";
final String string = "<h1> // MATCH!\n"
+ "<h3> // MATCH!\n"
+ "<h6> // MATCH!\n"
+ "h7 // NO MATCH!\n"
+ "<h7> // NO MATCH!\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}