$re = '/<h[1-6]>/';
$str = '<h1> // MATCH!
<h3> // MATCH!
<h6> // MATCH!
h7 // NO MATCH!
<h7> // NO MATCH!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);