using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h[1-6]>";
string input = @"<h1> // MATCH!
<h3> // MATCH!
<h6> // MATCH!
h7 // NO MATCH!
<h7> // NO MATCH!
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}