re = /<h[1-6]>/
str = '<h1> // MATCH!
<h3> // MATCH!
<h6> // MATCH!
h7 // NO MATCH!
<h7> // NO MATCH!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end