package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<h[1-6]>`)
var str = `<h1> // MATCH!
<h3> // MATCH!
<h6> // MATCH!
h7 // NO MATCH!
<h7> // NO MATCH!
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}