using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\B(?!\w)|\b(?=\w))(?:\(not working text|working text)(?:(?<=\w)\b|(?<!\w)\B)";
string substitution = @"<mark>$&</mark>";
string input = @"working text and (not working text";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}